Angular2.beta.14 with PrimeNG

Hello I was using angular2.beta.4 but when I tried to install PrimeNG, that requires angular2.beta.13, it didn’t work. So, I installed angular.beta.14 but I still got the following errors:

The package angular2@2.0.0-beta.14 does not satisfy its siblings'       peerDependencies requirement
Peer primeng@1.0.0-beta.1 wants angular2@2.0.0-beta.13

Can’t angular2.beta.14 run packages for previous versions ?

1
Leave a Reply

avatar
1 Comment threads
0 Thread replies
0 Followers
 
Most reacted comment
Hottest comment thread
1 Comment authors
Jason Recent comment authors
  Subscribe  
newest oldest most voted
Notify of
Jason
Guest

i wouldnt recommend doing that, since beta.14 does contain some breaking changes, for e.x the Dependency Injection now requires the annotation .. constructor(@Inject(ElementRef) ele : ElementRef){} instead of constructor(private ele : ElementRef){}

AFAIK PrimeNg Works with angular beta 9 versions.